E-Mail Issues

Incident Report for Flambeau Inc.

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 06:29 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2026 - 05:23 CDT

Identified

We are aware of the current email issue and our team is actively working to resolve it. We will keep you updated as we make progress.
Posted Apr 06, 2026 - 04:29 CDT
This incident affected: E-Mail.